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Keyboard
Keyboard short cuts:

F1 Help.
F2 Display Current Balance
F3 Write Check.
F4 Checking Deposit.
F5 Bump date up    (While in Transaction Dialogs).
F6 Bump date down    (While in Transaction Dialogs).



Commands
Menu choices with an asterisk* are only available at certain times.

FILE
DATA*
CHECKING
SAVINGS
TOOLBOX
WINDOW*
COMMON*
HELP



Dialog Boxes

LOAD Prompts for Account ID to load new account.    Previous accounts
are automatically saved.

TRANSACTIONS These dialogs are the actual transactions.
PICK A MONTH Prompts for a month to display a Register or Statement.
EDIT/DELETE Allows editing of Common Transactions.
FIND Prompts for information to find a transaction.
SETTINGS Prompts for program options.
CURRENT BALANCE Displays Current Balance.
FORM ATTRIBUTES Defines a check form for printing.
CHECK FIELD ATTRIBUTES Defines a text field on a check form.
TRANSACTION DETAILS Details about a transaction are entered here.
SPLIT Allows for transaction dollar amounts to be split over multiple 

categories.
EDIT CATEGORIES Allows for editing/deletion of transaction categories.
REPORT GENERATOR Allows for report printing.
SELECT PRINTER Allows for printer selection.



Overview
WinCheck is a checkbook program for Microsoft® Windows Version 3.00. It allows the user to
enter and track their transactions for a savings and a checking account.

All account information is stored with the file extension of the account ID (requested upon 
startup).    This way, if you have two accounts, you can use two sets of IDs.

Valid account ID's are 1-3 characters in length, only A-Z, 0-9 characters are allowed.



FILE

Load Account Brings up the Load dialog to change accounts.
Display Register Brings up a check register for a specified month.
Display Statement Brings up a bank statement for a specified month.
Display Current Balance Brings up the Current Balance dialog.
Close* Closes the active Register or Statement Window.
Find Brings up the Find dialog.
Edit Categories Brings up the Edit Categories dialog.
Report Generator Brings up the Report Generator dialog.
Export* Exports the active register window to a tabbed text file which is 

readable by Microsoft Excel®, 1-2-3®, etc.    See Export.
Check Form Setup Brings up the WinCheck Form Designer, which allows you to edit 

and create templates for printing on different check forms.
Select Printers Brings up the Select Printer Dialog, which allows for selection of 

separate printers (or the same) for reports and checks.
Printer Setup Allows for configuration of installed printers.
Settings Brings up the Settings dialog.



DATA*

Print Checks Prints selected checks. See Printing Checks.
Sum Highlighted Amts Sums the highlighted amounts and displays the total.
Clear Tags selected transaction(s) as cleared by the bank, indicated by an

asterisk.    The "BnkChk" or "BnkSav" columns will indicate the 
"Banks opinion" on your account.

UnClear Untags selected transaction(s).
Delete Deletes selected transaction(s).
Display Uncleared When checked, filters out cleared transactions from Statement.
Headings Add/Remove header from the active Statement/Register.
Sort ->

By Date* Sorts register by date.
By Number* Sorts register by check number.
Date,Number* Sorts register by Date, then Number.
Number,Date* Sorts register by Number, then Date.
Checks by Date* Sorts statement check section by date.
Checks by Number* Sorts statement check section by number.



CHECKING

Check Brings up the Write Check dialog.
Deposit Brings up the Deposit dialog.
Cash Machine Brings up the Cash Machine dialog.
Misc Brings up the Make your own dialog.
XFer Savings to CheckingBrings up the Transfer Savings to Checking dialog.
XFer Checking to SavingsBrings up the Transfer Checking to Savings dialog.
Interest accrued Brings up the Checking Interest Accrued dialog.



SAVINGS

Withdrawl Brings up the Savings Withdrawl dialog.
Deposit Brings up the Savings Deposit dialog.
Cash Machine Brings up the Savings Cash Machine dialog.
Misc Brings up the Make your own dialog.
XFer Savings to CheckingBrings up the Transfer Savings to Checking dialog.
XFer Checking to SavingsBrings up the Transfer Checking to Savings dialog.
Interest accrued Brings up the Checking Interest Accrued dialog.



TOOLBOX
Displays the Icon-Based toolbox (mouse required).

 Check

 Deposit

 Withdrawl

 Cash Machine

 Misc

 XFer Savings to Checking

 XFer Checking to Savings

 Interest accrued



WINDOW*

Cascade Cascades the Register/Statement Windows.
Tile Tiles the Register/Statement Windows.
Arrange Icons Arranges any minimized Register/Statement icons.



COMMON*

ADD -> Brings up the requested Common Transaction dialog. A common
transaction is one that you make usually on a monthly basis 
(such as a car payment).    You can fill in as many fields as you 
wish.    Maximum 32 Common transactions.

Edit/Delete Allows you to change or delete Common Transactions.
Date/Transaction/$$$* These menu items represent the common transactions created 

with the Add menu choice. When you select these choice(s), the
appropriate transaction will appear, with the month of the date 
set to the current month in the active register.    If no active 
register is present, the system clock month will be used.



HELP

Index Displays the Index.
Overview Displays the Overview.
Keyboard Displays the Keyboard Controls.
Commands Displays the Menu Commands.
About Displays the About dialog.



LOAD
This allows you to load in another account.

OK Loads new account.
CANCEL Does not load new account.

If the account is password protected, the user will be prompted for a password after pressing
OK.

Note: Only one account can be loaded at a time.



TRANSACTIONS
These are the checks, deposits, cash machines items, etc.    Use the TAB key to move 
between fields.

OK Adds this transaction.
CANCEL Does not add this transaction.
ANOTHER Adds this transaction, clears fields.
DETAILS Brings up the Transaction Details dialog.
PRINT Prints this check (or adds it to the Check Queue).

Hint: While on the Date field:

F5 Moves back a day.
F6 Moves ahead a day.

Note: A maximum of 16 transaction dialogs can be displayed at any one time.
The Type drop down listbox allows you to specify the category of the transaction.    By 
default, all transactions are Personal.    To add more types, simply type the new type into the 
edit field of the drop down listbox. If the type already has been entered, it can be selected 
from the listbox.

If the type is "Split..." the Split Dialog will appear after the transaction has been completely 
entered by pressing the OK or ANOTHER button.

Exported files are divided by category.



PICK A MONTH
This dialog appears when you open a Register or a Statement.    Select the month and year 
you want.

OK Opens this register/Statement.
CANCEL Does not open.



EDIT/DELETE
Displays a listbox with the Common Transactions dialog.

EDIT Edits the selected Common Transaction.
DELETE Deletes the selected Common Transaction.
LEAVE Exits this dialog.

Hint: Double Clicking on a Common Transaction edits it.



FIND Transaction
Allows you to search for a string or types of transactions.

Search Range Determines the dates to search.    Can be:
Search Current Month Only
Search ALL months
Search from: (fill in month/year -> month/year).

Trans: Determines the transaction to search for.
Type: Determines the category of the transaction (Personal, etc) to 

search for.
Amount: Determines the amount to search for.    If left blank, then the 

search will consider any amount (wildcard).
Check #: For checks only, indicates the check number.    If left blank, then 

the search will consider any number (wildcard).
Keyword: For checks and Miscellaneous transactions only.    If the keyword 

in the field is in the To line for a check, or the Description line of 
a Misc, the search will consider it.    If left blank, the search will 
consider all descriptions (wildcard).

SEARCH Start the search.
CANCEL Don't Search.



EXPORT
When selected, a file with a extension of the Account ID is created.    The file is saved in a 
tabbed text format which is readable by most other programs such as Microsoft Excel®, 1-2-
3®, etc.

The filename consists of EXPmmyy.iii, where:

mm The Month of the exported register.
yy The Year of the exported register.
iii The Account ID.

Example: EXP0990.TUT,    for September, 1990 Month, account TUT.



SETTINGS
Allows you to choose the preferences of WinCheck.

Default Register Sorting Determines how to sort the Register.    This can be changed for 
each Register window at any time; this is purely the initial sort 
method.

Default Statement Sorting Determines how to sort the Statement.    This can be 
changed for each Statement window at any time; this is purely 
the initial sort method.

Check Type Endstub checks have a different Tab field order than 
conventional checks.    Otherwise, there is no difference.

Headings If checked, displays headings for the Register or Statement.
Transaction Wallpaper If checked, the transactions have a colorful texture (Color 

systems only).
Toolbox on startup If checked, the Toolbox appears when you start WinCheck.
Balance on startup If checked, the Balance dialog appears when you load an 

account.
Password Protection If checked, the user will have to enter a password when opening

the account.    There are two fields to enter the password into, 
both must match.

OK Saves preferences.
CANCEL Uses previous preferences.



CURRENT BALANCE
Allows you to view your balance and the bank's current balance.

OK Close Balance window.



The Register

The Register sheet, , is a window, which contains the transactions for the month in the 
caption.    

An optional header provides descriptions of each column:

Date The transaction Date.
# Check Number.
Description Description of transaction.
ChkAmt Amount of checking transaction.
ChkBal "Your Opinion" of your running balance.
BnkChk "Banks Opinion" of your running balance. Only transactions cleared 

are figured into this balance.
SavAmt Amount of savings transaction.
SavBal "Your Opinion" of your running balance.
BnkSav "Banks Opinion" of your running balance. Only transactions cleared 

are figured into this balance.

The Data menu allows you to specify a different sorting order.

Hints: Double Clicking on the header removes it.The Register sheet allows multiple 
selections, consult your Windows manual for Multi-Select Listbox 
procedures.Double Clicking on a transaction brings up the appropriate transaction
dialog box.

By selecting "Sum Highlighted Amts" from the "Data" menu, it is possible to see how much 
money is involved for the selected transactions.

Registers can be exported to a tabbed text file, readable by most spreadsheet programs.



The Statement

The Statement sheet, , is a window, which contains the transactions for a period of one 
month, starting on the date specified in the Settings Dialog.

An optional header provides descriptions of each column:

Date The transaction Date.
# Check Number.
Description Description of transaction.
ChkAmt Amount of checking transaction.
SavAmt Amount of savings transaction.

Hints: Double Clicking on the header removes it.The Statement sheet allows multiple 
selections, consult your Windows manual for Multi-Select Listbox 
procedures.Double Clicking on a transaction brings up the appropriate transaction
dialog box.



Common Transactions
Common Transactions are those which are made regularly, such as rent, mortgage, utilities, 
food, etc.    WinCheck allows you to define up to 32 "templates", or "Common Transactions", 
which allow you to quickly enter the transaction.    Create templates using the "Add" menu 
choice, change or delete them through the Edit/Delete dialog.

As you add common transactions, they will be added to the Common menu.    Choosing 
these transactions immediately brings up a filled transaction dialog which you can change if 
necessary before saving by pressing OK.

Note: If you add details to a common transaction, they will be copied over to each new 
check created.    This is useful for placing information that does not change (such 
as account numbers, recipient's addresses, etc) on every common check written.   
For example, if you make a credit card payment every month, you can put the 
account ID in the Memo Line of the Details of the common check.    When you 
select the credit card check from the common menu, the account number will 
automatically be placed in the Memo Line.



WinCheck Form Designer
The Form Designer allows you to create, edit, and select check templates for printing:

Form Designer Overview
Adding a New Template
Edit an already existing Template
Select a Template
Form Attributes Dialog
Check Field Attributes
Transaction Details Dialog



Form Designer Overview

Create: You can add text fields to the template.    Move the mouse cursor to 
where you want to place the text field.    Press the INSERT key, or 
double click on the Right mouse button.    You will see a Check Field 
Attributes dialog.    Enter the information and press OK.

Edit: You can move text fields around to align to your check forms by 
clicking and dragging them with the mouse.    The text fields will 
align on a character basis, which depends on your Form Attributes 
settings.You can delete a text field by moving the cursor over the 
field, and pressing the DEL key.    The cursor will change into a 
crosshair when you move over a field.Double Clicking on a text field
will bring up the Check Field Attributes dialog.Double Clicking on 
the workspace will bring up the Form Attributes dialog, or Select the
File... Form Attributes menu option.

Select: You can select the template to use for WinCheck by choosing the 
File... Load option in the Form Designer.



Adding a New Template
If you get a WinCheck template file, you will want to add it to your Template List.    Choose 
the File... Load option to load the template.    Enter the filename (without extension) in the 
Filename field, and press OK.    Make sure the template is the way you like it.    Then, choose 
File... Save & Add to add this template to your list.    Future Load File dialogs will display the 
template description in the listbox for easy retrieval.



Edit an already existing Template
Choose File... Load to bring in the template.    Edit the template.    Choose File... Save to save 
them template.    If the template is not in your list, you may want to choose File... Save & 
Add.



Select a Template
Choose File... Load to load in the template.    This will automatically select this template as 
the printing template.



Form Attributes Dialog
This dialog box defines the check form you are printing on.

The form is the size of a single check.    Therefore, if you have three checks per page, your 
dimensions would still be for only one of those checks.    In this case, be sure to specify "3" in
the Forms Per Page field.

Lines Per Inch: This defines the number of lines per inch your form is designed for.  
Almost every form is designed for 6 lines per inch (the default 
value).

Characters Per Inch: This defines the number of characters per inch your form is 
designed for.    Almost every form assumes 10 characters per inch 
(default).

Form Vertical Size: This defines the number of lines for a single check.    For example, if
you have a check that is 3.5 inches deep, and you are printing at 6 
lines per inch, then your check would be 21 lines long.

Form Horiz Size: This defines the number of inches wide your form measures.    
Typically 8 inches (default).

Forms Per Page: This defines the number of checks that fit on a single printer page.   
A check queue will be the size of this number (1-5).    As you print 
checks, this queue will fill up.    When the queue is full (or when you 
exit WinCheck), the queue will print.    This allows laser printer 
forms with three checks per page to print all three checks at once.If
you are using a dot matrix printer, you may find it annoying that a 
Form Feed is produced after printing a check.    This is a limitation of
Windows.    Therefore, by specifying the number of checks per page,
you can print a pageful of checks at a time, reducing the number of
times you need to "Wind the printer back".



Check Field Attributes Dialog

Chars Wide: This defines the number of characters wide the text field may be.
Lines Deep: This defines the number of lines deep the field may be.    Generally 

the field is one line deep, with the exception of the address field.    
In this case, it should be four lines deep.

Check Field Type: This allows you to define the type of text field.    There are seven 
standard fields, plus a custom field.    The standard fields will be 
automatically filled in when you print the check.    The custom field 
will print the text you enter in this dialog.



Transaction Details Dialog
This dialog allows you to save additional information about a transaction.    Information 
entered in the Memo Line field will be printed in the Memo Line field(s) when printing 
checks.    Information entered in the address section will be printed in the address field(s) 
when printing checks.    Comments are not printed.



Split Transaction Dialog
Splitting a transaction takes place after you have pressed the OK or ANOTHER button on a 
transaction if the "Type" field displays "Split...".

Amount Accted For This is how much money has been assigned a category.
Amount Remaining This is how much money is not assigned to a category.    This 

number must be 0.00 in order to leave the Split Dialog.
ADD Assigns the amount in the edit field to the category in the Type 

field, and adds it to the list of assigned amounts.
DELETE If an amount is selected in the list, this will delete it.
MODIFY If an amount is selected in the list, this will replace it.
HELP Brings up this help screen.
OK Accepts the list.

Example: You have written a check to your stockbroker for $1000.00.    Of this 
amount, $500.00 is for stock, $250.00 is for a money market, and 
$250.00 is for a margin call.

1. Enter the check for $1000.00, and make sure that the type field displays "Split...".
2. Press OK or ANOTHER to bring up the Split Dialog.
3. Type "500.00" into the Amount field, and select "Stock" in the type field.    If this 

category does not exist, type the word "Stock" into the field.
4. Press ADD.
5. Type "250.00" into the amount field, select "Money Mkt" (or type it in), and press 

ADD.
6. Do the same for "Margin".
7. Press OK.



Filenames
WinCheck templates have the file extension WCT.    You do not need to enter this extension 
when indicating the filename to load or save.    WinCheck will automatically add the file 
extension.



Hints and Tips

Take advantage of the Misc transaction, .    Direct Deposits, automatic withdrawals, 
service fees, and more can be entered here.

Take advantage of the Type field in the Transaction dialogs. You can accurately and carefully 
track your finances this way.

Register this product!    By registering this product, you will keep informed about updates, 
and you will keep me motivated to make more nifty windows apps.



Printing Checks
Here are the steps that should be taken when you get ready to print checks the first time:

1. Purchase computer check forms from your favorite dealer.

2. Start up WinCheck, do not put check forms in printer yet.

3. If you are using the NEBS General Purpose Laser Check, part number B9039-1,    
choose"Load Form Template" from the WinCheck Form Designer (Activated by choosing 
"Check Form Printer Setup" from the "File" menu of WinCheck).    Select the default 
LaserJet II Template (even if you don't have a LaserJet II).    NEBS can be reached at 1-
800-225-9550.

4. If you want to create a new check form,    choose "New Form Template" from the 
WinCheck form designer.    Create the fields to fill in for your check (double clicking the 
right button on the mouse adds a new field, or press the Insert key).    Describe the 
attributes of the field(s). Double clicking with the left button on an already existing field 
will allow you to edit the attributes.    Double clicking with the left button on the 
"workspace" of the WinCheck form designer will allow you to describe your form 
attributes.Form attributes describe the size of one    check.    If you are using a laser 
printer, describe the full page (unless your check form has multiple checks per page).    If 
you are using a dot-matrix printer, describe one check.    If three checks fit on a page, 
you can indicate this.

5. Once you have described the "rough draft", print a test form on blank paper.    Hold the 
blank paper against your check form, and make sure all of the fields line up (you can use 
a lightbulb to see though the papers).    Click and drag fields to line them up.

6. Repeat step 5 until your rough draft is OK.    If you have not saved this template before, 
choose "Save &Add" from the WinCheck form designer.    Describe your template 
however you want, and pick a filename.    If you have previously saved your file, just 
choose "Save".

7. Now you are ready to print checks!



Printing Reports
Report Generator Dialog

WinCheck has a report generator that allows for printing and viewing reports.    Bring up the 
Report Generator Dialog from the "File" menu.    Select the starting month of the report span,
then select the ending month.    Select the report type you wish to view.

Pressing the "View" button gives a quick look at the report on the screen.    It is not possible 
to page backwards through the report.

Pressing the "Print" button prints the report on the printer specified in the Select Printer 
dialog.



Selecting Printers
Choosing "Select Printer" from the "File" menu will bring up the Select Printers dialog.    For 
each type of printout (Checks, Reports), choose a printer.    When complete, press OK.    To 
use the default printer (the one selected in Control Panel), press USE DEFAULT, and OK.



Transaction Categories
Transaction categories, or types, are used to differentiate expenses.    For example, the 
categories "Personal", "Auto", "Home", "College", and "Tax Deductible" could be used.    
WinCheck starts a new account with the type "Personal".    If you want to add more 
categories, just type the new category in the "Type" field while entering the transaction.

It is possible to split a transaction over several categories.    To do this, select "Split..." in the 
"Type" field of the transaction.    Once you press the OK or ANOTHER button, the Split Dialog 
will be displayed.

It is possible to edit the category names by selecting "Edit Categories" from the File Menu.



Password Protection
WinCheck allows for password protection of data.    In the Settings Dialog box, check the 
Password Protection box, and enter the same password in both edit fields.

For your safety, Wilson WindowWare will not assist users in recovering data due to forgotten 
or lost passwords.



Editing Categories
To edit categories, choose "Edit Categories" from the "File" menu.

Select a category from the list.
Pressing "Delete" will remove the category.
To modify a category, select it, type the new decscription in the edit field, and press 
"Modify".

Note: Deleting a category is a permanent decision.    Make sure that none of your 
transactions are still using this category.    WinCheck will not lose these 
transactions, but the reports will place these dollar amounts in a category titled 
"Deleted".

Modifying a category will change that category description throughout your entire register.    
For example, changing "Business" to "Pleasure" will affect every "Business" transaction in 
your account.

It is not possible to delete or modify the category "Personal".



WinCheck Messages
The following is a list of Messages WinCheck may display, and their explanations/solutions.

Too many open Transactions.
WinCheck can display up to 16 transaction dialogs simultaneously.    However, only one 
new transaction is allowed.

Not Enough Memory. Close some Registers/Statements, and try again.
Too low on memory to do anything (xxx Bytes). Close some registers/statements/other apps 
and try again.

WinCheck requires about 256K of memory to run efficiently.
Limit Reached on Common Transactions

WinCheck can keep track of 32 Common Transactions.
There is no data to search.
There is no data to calculate.
There is no data to password protect.

WinCheck will not search, or display registers/statements/reports until a transaction has 
been entered.

Too many matches!
WinCheck can display up to 100 matches during a search.    Matches over 100 are not 
displayed.    The "total" figure, however, is accurate.

The date is incorrect. Please use MM/DD/YY format.
Example: 03/09/91

Negative Sign Unnecessary.
WinCheck automatically adds or subtracts the amount from the register.    In the case of 
Miscellaneous transactions, use the "Credit" checkbox to indicate deposits to your 
account.

Warning: $.$$$ changed to $.$$
WinCheck rounds transactions to the penny.

Invalid ID- Please use characters and numbers only.
WinCheck must have an account ID of 1-3 characters, A-Z, 0-9 only.

Unknown Data Type.    Using Default Data Type
Your data files my be corrupted.    Check your register.

Error While PrintingPrinting Aborted
Refer to your Windows owner's manual for printing problems.

Please do not enter a file extension. WinCheck will automatically add .WCT to the filename
All WinCheck templates must have .WCT as the extension.

Unable to access printer driver. Check to make sure the printer is active via Control Panel
Failure to Load Printer DLL
Failure to Access Printer DLL

An error occurred while loading the Windows Printer Driver.    Consult your Windows 
Owner's manual for printing problems.

Added Check to Check Print Queue
WinCheck has queued up this check for printing.    It will print it when the queue is full, or 
when you exit WinCheck.

All money must be accounted for.
Number must be less than or equal to amount available

When splitting transactions, the sum total must equal the total amount of the 



transaction.
WARNING: Deleting a category can leave transactions with unresolved categories. Continue?

WinCheck wants to make sure all your money is categorized in other areas.    Otherwise, 
WinCheck reports will have amounts under the category "Deleted".

Field(s) blank on transaction. Discard?
WinCheck will use $0.00 for a blank amount field.

Only one new transaction allowed at a time. Please complete the current new transaction.
WinCheck allows only one new transaction to be entered at a time to help avoid 
confusion.

Password and Verify Fields do not match.
WinCheck wants to make sure your typed your password correctly.


